Error on Raspberry PI 4 while opening TensorFlow.



  • Hi,
    I came by this error after installing TensorFlow in RPI 4
    can you guys find a fix?
    error on Raspberry PI 4

    tensorflow/core/platform/hadoop/hadoop_file_system.cc:132] HadoopFileSystem load error: libhdfs.so: cannot open shared object file: No such file or directory)
    

    1.JPG 3.JPG 2.JPG



  • Your are using a bleeding edge python software for tensorflow. I believes it is python 3.7 or python 3.8 or something. Try to downgrade your python to 3.6.5 or other compatible version by refereing documentation.



  • @arunksoman hi, i've run this code using python 3.7 on anaconda and it worked fine.
    but as i run this on RPI 4, it showed the Hadoop error. I then updated the libraries and Hadoop error was solved..
    now there is a new error
    2020-03-30 (1).png 2020-03-30 (2).png

    also can you take a look in the 10% memory error?...like what can be possibly done there??



  • @sreu13 What is the version of tensorflow you are using? Did you read the tensorflow docs? You can't do simply
    pip install tensorflow
    for Python 3.7 version.



  • @arunksoman i installed tensorflow from the below given link

    https://maker.pro/raspberry-pi/projects/how-to-set-up-the-machine-learning-software-tensorflow-on-raspberry-pi

    and i installed it without entering into virtual environment

    but this 10% memory issue is a serious pain



  • @arunksoman tensorflow 2.0.0 version had been installed



  • @sreu13
    Ensure that you are installed tensorflow 1.x since screenshot of your code shows something like
    from keras.layers.convolution import covolution2D
    It is not correct in case for tensorflow 2.0 since keras api is part of tensorflow itself.

    Another thing is try to expand your file system. It should be do with your own risk.

    1. sudo raspi-config
    2. Navigate to Advanced options
    3. Select advanced options and hit enter(I believes tab key is useful here)
    4. Choose Expand File System and hit enter finish.
    5. Then your pi may prompt to reboot. If it didn't run. Execute
      sudo reboot
    6. Then execute following commands one by one:
    $ sudo apt-get purge wolfram-engine
    $ sudo apt-get purge libreoffice*
    $ sudo apt-get clean
    $ sudo apt-get autoremove
    
    1. Then increase swap memory by editing following file swapfile:
      $ sudo nano /etc/dphys-swapfile
    2. It will open nano editor. Navigate to variable
    CONF_SWAPSIZE=100
    

    It indicates your current swap is only 100mb.
    So you just have to increase by commenting down this line and increase to appropriate value something like shown below for 2GB swap:

    #CONF_SWAPSIZE=100
    CONF_SWAPSIZE=2048
    
    1. Save the file and exit nano editor.
    2. sudo reboot

    I believes if it did not helped you, you have to think about MOVIDIUS or NVIDIA Jetson nano etc.



  • @arunksoman i'll try this method, but while executing swap command, will the rasbian os and the files it contains be effected??



  • @sreu13 I edited comment please read that again. Most probably it will not effect your file system. In some scenarios it can create worse effect.



  • @arunksoman hi,..
    actually at this point of time, I'm not willing to risk RPI4,....i thought of connecting the rpi4 to google cloud (already have an account with $300 credit) and proceeding with the code.
    but i do not know if the below process can be executed

    1. sending image from rpi4 to cloud
    2. using this cloud for running prediction
    3. the above two processes should be automated and image should be sent to cloud when pi boots up(VM engine can be activated whenever nessesary)

    is this possible?


Log in to reply
 

Recent Posts

  • F

    @salmanfaris best if you could point me to an example that works as described: getting different values depending on hoe close the finger is without really touching. nothing i tried did work yet

    read more
  • F

    @salmanfaris I haven't found a good sensor module for this at all. I used a thing which was calles touch sensor and it returns only 1/0. Tried to use touchRead() but it is not sensitive apparently, only 40 and 1 more or less.

    #define touch_pin_numer 33

    const int VALUE_THRESHOLD = 30;
    int TOUCH_SENSOR_VALUE;
    void setup()
    {
    Serial.begin(115200);
    delay(1000);

    }
    void loop(){
    TOUCH_SENSOR_VALUE = touchRead(touch_pin_numer);
    Serial.println(TOUCH_SENSOR_VALUE);
    if(TOUCH_SENSOR_VALUE < VALUE_THRESHOLD)
    {
    Serial.println ("Touch ON");
    }
    else{
    Serial.println ("Touch OFF");
    }
    }

    should show something between 40 (current max) and 1 (current min) the closer the finger gets but it shows 40/41/39 and 1 - nothing inbetween. got this code from the web

    read more
  • @FlorianB Can you share the code, output window/error and details of the sensor module?

    read more
  • F

    Hi! I am trying to add an capacitive sensor to the ESP32, that will work through glass with 3mm thickness and an distance of 8 to 2 cm. I have bought sensors which only work on touch, i have looked into the touchRead() function but cant get a steady value increase/decrease with distance and only a real touch gets me enough difference to count it as a "touch". I have checked Arduino examples with foil where a resistor can set the sensitivity but nothing worked on my ESP32. i have spent hours looking for an example, can somebody point me to one please?

    read more
  • Capture.PNG

    Welcome to the Second edition of MakerGram Live, a newsletter where we pull together information about Interesting projects, Industry news, upcoming events, job opportunities and other interesting bits that you may find useful. 😉

    If you are a member of makergram, you already received a mail, please check your inbox or you can read from here: MakerGram Live | May 2020 Maker Update

    read more